Checkout Disruption

Incident Report for Scaled Agile Status Page

Resolved

This incident has been resolved.
Posted May 05, 2026 - 15:47 MDT

Investigating

We’re currently experiencing issues with checkout due to a payment provider disruption. Please hold off on making purchases for now. Updates will be shared as soon as service is restored.
Posted May 05, 2026 - 10:21 MDT
This incident affected: Studio (Studio Application).