Login Issues

Incident Report for Scaled Agile Status Page

Resolved

This incident has been resolved.
Posted May 06, 2026 - 14:46 MDT

Investigating

We are currently investigating reports of users being unable to log in. Our team is actively working to identify the cause and restore service.
Posted May 06, 2026 - 14:21 MDT
This incident affected: Studio (Studio Application).